Server Busy errors

Incident Report for Jobable

Postmortem

Yesterday afternoon, approximately 10-15% of individual users experienced “Server Busy” errors. The issue was traced to a third-party process that repeatedly restarted itself. This caused the server to operate the edge of its allowable process limits. Our team stopped the process and service was returned to normal. An alternative process has been implemented to prevent recurrence.

Posted Aug 15, 2025 - 13:22 UTC

Resolved

Some users report Server Busy errors.
Posted Aug 14, 2025 - 15:30 UTC